Back to overview
Resolved

Verification link expires before opening

Jun 2, 2026 at 3:57pm UTC
Yang terdampak
API (Jakarta, Singapore)
Email Service (Jakarta)

Resolved
Jun 3, 2026 at 1:48pm UTC

We have identified the issue and also implemented the fix.

We are also actively monitoring this for the next 24 hours, but for now, we marked this issue as resolved.

Updated
Jun 3, 2026 at 12:37pm UTC

We are reopening this status as our previous patch didn't resolve the issue.

And, we are actively investigating the issue.

Updated
Jun 2, 2026 at 4:48pm UTC

We issued a mandatory challenge provided by Cloudflare, specifically on the verification link. We'll be monitoring the result for the next 24 hours.

Created
Jun 2, 2026 at 3:57pm UTC

We have identified the issue of why the verification link expires so early, and we're currently implementing the fix.