Back to overview
Degraded
Unable to open blogs
Feb 12, 2026 at 04:17am UTC
Affected services
anthro.id (Jakarta)
Resolved
Feb 17, 2026 at 05:07am UTC
The issues were resolved.
Affected services
Created
Feb 12, 2026 at 04:17am UTC
We're currently investigating the issue of why the blog page won't load.
Affected services